cisco
Windows

How to Configure Router with switches

In this blog I’ll configure two router with two switches in packet tracer. This configuration is for cisco routers and switches.

Packet Tracer is a network simulator software. It simulates networking devices that are used to build CCNA practice labs. An average CCNA lab costs more than $300. A packet tracer cuts this cost by simulating all essential CCNA lab devices. A simulation-based learning environment helps students and instructors.

*Now here we start how to Configure Router with switches*

Making small network

First we take a small network to make our installation easily and quick with 2 routers, 2 switchs and 6 pcs or end users.

To connect the pcs with the switch we need copper straight cable and to connect the routers with each other we have to add serial port in the router as shown as follows:

To connect the serial port of the router with each other we need serial DCE cable to connect.

Now configure the network now we give static IPs to the end Users pcs as shown in the picture:

The IP is given to Pc0 is 192.168.10.2 subnet mask 255.255.255.0 and Default Gateway 192.168.10.1 to make the network different.

Like wise we give IP to PC1 and PC2 as shown:

Like wise we configure the other network PC3 IP: 192.168.20.2 Subnet Mask: 255.255.255.0 Default Gateway: 192.168.20.1. Configure the PC4 and PC5 vise versa as shown:

Configure the Routers

Now click on the router0 and go to CLI and run the following commands:

Router>enable

Router#

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#interface Serial0/1/0

Router(config-if)#no shutdown

Router(config-if)#clock rate 128000

Router(config-if)#ip address 192.168.30.2 255.255.255.0

Router(config-if)#ip address 192.168.30.2 255.255.255.0

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 192.168.10.1 255.255.255.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Then we have to do same configuration on router1 and run the following commands:

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#

Router(config)#interface Serial0/0/0

Router(config-if)#ip address 192.168.30.3 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial0/0/0

Router(config-if)#clock rate 128000

Router(config-if)#exit

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 192.168.20.1 255.255.255.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Now we have to define the common route between the routers0 and router1. To do this we have to open a CLI in router0 and enter the following commands:

Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.30.1

Router(config)#exit

Router#

%SYS-5-CONFIG_I: Configured from console by console

Now open CLI in router1 and enter the following command:

Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.30.1

Router(config)#exit

Router#

%SYS-5-CONFIG_I: Configured from console by console

Now we have to run the simulation to check our configuration in real time. Click on the simulation and send ICMP package and check the result.

This is how you can configure two router with two switches in packet tracer on different gateways.

Leave a Reply

Your email address will not be published. Required fields are marked *