PHP
Centos Linux Ubuntu

[Solved] E: Unable to correct problems you have held broken packages

In this blog I try to [Solved] E: Unable to correct problems you have held broken packages while installing php on Ubuntu 20.04.

I uninstalled php, but not it’s dependencies, so there are still leftovers from the ppa (I guess it was ppa:ondrej/php).

Try autoremove, it may already be enough:

$ sudo apt autoremove

manually uninstall the packages in question:

$ sudo apt remove php7.4-common

If that is not enough, it might help adding the ppa again and remove with ppa-purge:

$ sudo add-apt-repository ppa:ondrej/php
$ sudo apt install ppa-purge
$ sudo ppa-purge ppa:ondrej/php

I hope the it can solve your error as well of php while installing on Ubuntu 20.04.

I hope the it can[Solved] E: Unable to correct problems you have held broken packages with php while installing on Ubuntu 20.04.

Leave a Reply

Your email address will not be published. Required fields are marked *